Help Center Unavailable
Incident Report for TeamSnap
Resolved
This incident has been resolved.
Posted Jul 08, 2022 - 16:13 MDT
Monitoring
A fix has been implemented and the Help Center is back online. We will continue to monitor for any further issues.
Posted Jul 08, 2022 - 15:59 MDT
Investigating
We are currently experiencing an outage of our Help Center. We are actively working with our Help Center provider to resolve this as quickly as possible. You can still reach support, by logging into your TeamSnap account and using the help icon in the lower right of your screen. Updates from our provider can be found here: https://status.helpscout.com/incidents/4wnlmjm4mfvr
Posted Jul 08, 2022 - 15:58 MDT
This incident affected: TeamSnap Customer Experience (Help Center and Support).