TeamSnap Payments Issues
Incident Report for TeamSnap
Resolved
We have confirmed that payments are processing successfully again.
Posted Jan 18, 2018 - 13:39 MST
Monitoring
We have seen some issues with collecting payments. It appears to be resolved and we are monitoring the fix.
Posted Jan 18, 2018 - 12:06 MST