Email delay
Incident Report for TeamSnap
Resolved
The issue with email delays has been resolved. Please reach out to our support team if you are still experiencing an issue: https://helpme.teamsnap.com/?solvvy=true .
Posted 3 months ago. May 27, 2019 - 09:57 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 3 months ago. May 27, 2019 - 09:49 MDT
Identified
We have identified an issue with our email provider causing email delays. We are working with them to resolve the issue and will continue to monitor.
Posted 3 months ago. May 26, 2019 - 13:14 MDT
Investigating
We are currently experiencing email delays affecting new games/events created, game/event updates and some general team emails. We are investigating the issue and will continue to post updates.
Posted 3 months ago. May 26, 2019 - 12:20 MDT
This incident affected: Email/SMS Delivery.