Location loading issue for sports organizations with 200+ league locations
Incident Report for TeamSnap
Resolved
The location loading issue has been resolved. Please reach out to our support team if you are still experiencing an issue: https://helpme.teamsnap.com/?solvvy=true.
Posted 5 months ago. Apr 05, 2019 - 11:00 MDT
Identified
For organizations with over 200 league locations, loading of locations when creating a team event may be slow. We are continuing to troubleshoot this issue.
Posted 5 months ago. Apr 04, 2019 - 20:27 MDT