System performance degraded
Incident Report for TeamSnap
Resolved
This incident is now resolved.
Posted Mar 22, 2023 - 09:54 MDT
Investigating
We are deploying a change to mitigate a temporary issue.
Posted Mar 22, 2023 - 09:43 MDT
This incident affected: TeamSnap iOS, TeamSnap Android, and Team/League Website.