We are investigating an issue preventing the upload of new art/logos to the Team Store.

Incident Report for TeamSnap

Resolved

This incident has been resolved.
Posted Mar 29, 2021 - 18:26 MDT

Investigating

We are currently investigating this issue.
Posted Feb 18, 2021 - 16:40 MST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 18, 2021 - 16:35 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 18, 2021 - 16:34 MST

Investigating

We are currently investigating this issue.
Posted Feb 18, 2021 - 16:32 MST