Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 20, 2025 - 22:00 MDT
Scheduled
We are planning maintenance on our systems on March 20th, 2024 between 10PM and 11PM MT. During this time customers may experience connectivity issues. We will post an update when the maintenance begins.
Posted Mar 20, 2025 - 21:08 MDT
This scheduled maintenance affected: Team/League Website, API/Mobile Apps, Tournaments, Email/SMS Delivery, and Push Notifications.