TeamSnap.com Slow Response Times

Incident Report for TeamSnap

Resolved

This incident has been resolved.
Posted Nov 07, 2024 - 13:40 MST

Identified

TeamSnap.com is experiencing some latency, but is recovering. We are working to resolve this as quickly as possible. This does not impact usability or mobile apps.
Posted Nov 07, 2024 - 11:24 MST

Investigating

We are currently investigating slow response times when accessing TeamSnap.com. This does not impact mobile apps or the Help Center (https://helpme.teamsnap.com/)
Posted Nov 07, 2024 - 10:28 MST